Email Sending Delays
Incident Report for Covidence
Resolved
This incident has been resolved.
Posted Oct 18, 2020 - 18:15 AEDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 17, 2020 - 07:00 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 17, 2020 - 07:00 AEDT
Investigating
Our email provider (Twilio Sendgrid) is having issues which are affecting us, and unfortunately until they fix them we'll have delays sending invitations and other emails.
Posted Oct 17, 2020 - 00:15 AEDT
This incident affected: Infrastructure (SendGrid SMTP).