Plans cannot be purchased
Incident Report for Covidence
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 09:13 AEDT
Investigating
Some users are unable to purchase a plan
Posted Feb 27, 2024 - 08:48 AEDT