Out of date review details
Incident Report for Covidence
Resolved
We have fixed all impacted accounts and no data has been lost in this process.
Should you have any further issues please contact Customer Support.
Posted Oct 18, 2022 - 01:33 AEDT
Identified
We have identified 750 impacted accounts where the list of remaining studies to screen is not showing as expected.
We are now deploying a fix and will update you once this is complete.
Posted Oct 17, 2022 - 22:03 AEDT
Investigating
We have identified an issue that is impacting users who have been actively screening studies between 11:30-16:00 AEST on Monday 17th October.

No data has been lost but the list of remaining studies to screen is not showing as expected. We are currently working on a fix for this. We will provide a further update on this shortly.
Posted Oct 17, 2022 - 16:22 AEDT
This incident affected: Covidence App (Search & Study Lists).